Bluetooth Doctor Your resource for Bluetooth Troubleshooting and Technical Support
 
Follow question

Altec Lansing Evolution 2 won't pair

This question relates to connecting an Altec Lansing Evolution 2 BUY NOW to an Apple iPhone 5S BUY NOW

Other users are having problems with these devices!   Be sure to check out similar posts in case they had the same issue

There are 2 other questions relating to the Altec Lansing Evolution 2 - click here to view.   2 of the answers are marked as solutions.

There are also 33 other questions relating to the Apple iPhone 5S - click here to view.
Troubleshooting tips
We have some extra troubleshooting tips for Apple iPhone 5S devices - click to view
MY ALTEC LANSING BLUETOOTH HEADSET JUST HAS A BLINKING BLUE LIGHT...AND WILL NOT PAIR WITH MY DEVICES. IT HAS BEEN WORKING GREAT...BUT NOW IT SUPPOSEDLY IS IN PAUSE MODE & WON'T CONNECT TO MY BLUETOOTH DEVICES...JUST SETS THERE WITH THE BLINKING BLUE ON/OFF BLUE LIGHT.
-
Question by W MILAM 6:40am, 26th August 2017

There are 5 responses to this question including 1 solution and 2 other deemed noteworthy

luis responded : 6:45pm, 12th September 2017 (3 years ago)
same problem here, did you found what is going on or how to fix it?


thanks

Jeremiah Boles responded : 8:53am, 14th September 2017 (3 years ago)
Plug in an aux cord. It will turn off the headphones and you should be able to turn them back on and reconnect with no problems. Worked for mine and I had the same issue

Chris Kelley responded : 7:20pm, 19th December 2017 (2 years ago)
Thanks Jeremiah! That worked like a charm. Makes sense as it shuts down the bluetooth service in the headphones. Much better than the other solutions I saw... wait until the battery dies then recharge and it would re-start.

Seems like a bug they should've fixed in the first place. Oh well, that is what $50 earphones are like.

Aquaman responded : 3:05am, 31st December 2017 (2 years ago)
Thanks so much for this! I was having a similar issue and yep! Plugged in an aux adapter and sure enough it turned off the Bluetooth and let me turn the headphones off and now it's working like a charm. Super appreciate you.

Sharon responded : 1:14am, 30th May 2018 (2 years ago)
Same problem; plugged in an aux adapter, blue light shut off. Powered up the headphones, paired it with my phone and now it works! Thank you so much!

Didn't fnd the answer you needed?   We have links to similar questions below that can help!

Can you contribute an answer to this question?

If you can assist the users problem you can quickly respond by completing the fields below to respond.

Other questions relating to Altec Lansing Evolution 2

Other questions that have solutions that may be able to help you ?!


Can you help other users with Altec Lansing Evolution 2 devices that have a problem outstanding?






< Back to questions list

Bluetooth Doctor is not responsible for, and expressly disclaims all liability for, damages of any kind arising out of use, reference to, or reliance on any information contained within the site. Never undertake manual repairs or modifications to hardware if without qualifications and always seek guidance from your retailer if you can't find a solution to your problem.
Need help finding a new Bluetooth device? View our shop