Bluetooth Doctor Your resource for Bluetooth Troubleshooting and Technical Support
 
Follow question

Nenrent S570 : Connected but there's no sound

This question relates to connecting a Nenrent S570 BUY NOW to a Tecno Pova DL7 BUY NOW

Other users are having problems with these devices!   Be sure to check out similar posts in case they had the same issue

There are 35 other questions relating to the Nenrent S570 - click here to view.   4 of the answers include responses marked as solutions.
The Bluetooth has been connected but there's no sounds at all... thanks.
-
Question by Nathan 10:53pm, 21st November 2021

There are 2 responses to this question

John (Admin) responded : 12:11pm, 23rd November 2021 (1 week ago)
So the device definitely states "connected" in the Bluetooth settings? Do you have any other audio devices still paired ? It's possible that these could be using the resources needed by the s570.

Nathan responded : 1:00pm, 23rd November 2021 (1 week ago)
Yeah, but I'll have to try another device and see if it will work

Didn't fnd the answer you needed?   We have links to similar questions below that can help!

Can you contribute an answer to this question?

If you can assist the users problem you can quickly respond by completing the fields below to respond.

Other questions relating to Nenrent S570




Want to shop for the devices discussed in this question?



< Back to questions list

Bluetooth Doctor is not responsible for, and expressly disclaims all liability for, damages of any kind arising out of use, reference to, or reliance on any information contained within the site. Never undertake manual repairs or modifications to hardware if without qualifications and always seek guidance from your retailer if you can't find a solution to your problem.
Need help finding a new Bluetooth device this Christmas? View our shop